PrerequisitesΒΆ

The following prerequisite software is supported in this version.

Operating systems

Vidispine server (VS):

  • Ubuntu 18.04 LTS (64 bit)
  • Red Hat Linux 7.0

Vidispine server agent (VSA):

  • Ubuntu 18.04 LTS (64 bit) [1]

Databases

  • PostgreSQL 9.6 and 11
  • MySQL 5.6 and 5.7 [1]
  • Microsoft SQL Server 2017 [1]

Java

  • Java 11

Other

  • Solr 8.1.0 (if installed manually)
  • Zookeeper 3.4.6 (for HA systems) [1]
  • Elasticsearch 6.8.1
  • ActiveMQ 5.15

Changed in version 5.0.

  • Support for Java 11 was added.
  • Support for Java 8 was removed.
  • Support for Solr 8.1.0 was added.
  • Support for Solr 4.10.0 was removed.
  • Support for Elasticsearch 6.8.1 was added.
  • Support for Elasticsearch 5.6.x, 6.0.x, 6.1.x and 6.2.x was removed.
  • Support for CentOS 6 was removed.
  • Support for Ubuntu 16.04 was removed.

Changed in version 4.17.

  • Support for PostgreSQL 11 and Ubuntu 18.04 was added.
  • Support for PostgreSQL 9.1, PostgreSQL 9.3, MySQL 5.5 and Ubuntu 14.04 was removed.
[1](1, 2, 3, 4) Vidispine Enterprise edition only.